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OptAll Pre-processing Software

Introduction

This note describes the pre-processing software for OptAll. The full package including soil moisture
balance and optimisation routines may be obtained on request from Dr Robin Wardlaw at the
University of Edinburgh. The pre-processor provides the means of defining the irrigation network
files for the optimisation package.

Network and System Definition Data

The model network file controls the basic links in the data base for the model. The operationa
interface for creation of anetwork fileiscalled OPTALL_NET.

OPTALL_NET is a computer program design to run under the Windows95 operating system. The
program permits the graphical design of a network of nodes and reaches on top of a map. Each node
and reach has a number of parameters, which can be edited through dialog forms. The network can be
saved or loaded from a file with extension an *.0IS. In addition to the nodes and reaches, the
program provides a set of graphic primitives to assist in creation of background schematics.
Alternatively, DXF files can be imported to create a map background

When the network is completed a network file is created which is in the correct format for the
optimisation model. The model can be executed from a within the OPTALL_NET program via a
menu option, although it is unlikely that this option would be included in afully functional system.

The current opening screen from OPTALL_NET is shown in Figure 1. The file option permits an
existing file to be opened, or a new file to be created. Thisis a standard windows feature, and it thus
possible to maintain good directory structures for model runs.

E}E Optimisation of Irrigation Systems

File “iew Help

(D)) [*[5=E] (S] 2] (2 S] [= =] [V @] -] (@] =]

Figure 1 Opening screen for OPTALL_NET

When afileis opened, then the full editing menu shown in 2 appears.

a) Display

OPTALL_NET is amulti document application. This means that it is possible to create or edit more
than one network at atime. Each network is shown in a scrolling window, which may contain a map.
Maps can be loaded from DXF files from the menu option *Maps ->" Import DXF Maps'.

A window shows a view on a map and network. This can be the entire area or a zoom a view into a

particular area. If the view is zoomed into an area the scroll bars on the left and bottom of the
windows will permit scrolling to see different areas of the map.
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Figure 2 Editing screen on selection of afile or creation of anew file

The ‘“VIEW’ menu contains options, which allow the display parameters to be changed. Here the area
viewed on the map can be changed by selecting to zoom out (show more map) or show the entire
map. To zoom into the map edit mode must be selected from the menu option ‘Tools ->'Edit data or
the toolbar/toolbox icon which looks like a magnifying glass. Then a rectangular area can be click and
dragged over the current map. There are menu options to go to a coordinate point or zoom to an area
by entering the coordinates. A grid can also be displayed to show the coordinates.

b) Network

The OPTALL_NET program operates in 2 modes, Designer and User mode. The operating mode is
selected from the menu option ‘Tools ->'Edit data’ for User mode or ‘Tools ->'Select’ , ‘Nodes
‘Reaches , 'Lines, 'Polygon’, 'Point’, ' Text” or ’Bitmap’ for design mode.

Alternatively the appropriate toolbar/toolbox icon can be selected. The icon that looks like a
magnifying glass selects User mode. A list is given below of which toolbar/toolbox icons do what
function. The toolbox operates in the same manner as the toolbar, but only contain the options for
selecting user or design mode functions. The toolbox can be show or hidden by selecting the menu
option ‘View’->"ToolBox'. The toolbox window is shown in Figure 3.
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Figure 3 Toolbox window

The toolbar/toolbox will indicate which mode has been selected by showing the appropriate icon
depressed. Also the mouse cursor will change to reflect the mode.

Designer mode allows new nodes or reaches to be added to the network. The position of the node or

reach can be changed by click and dragging components. A background schematic can be created by
adding graphic primitives such as lines, polygons, text, points, or bitmaps.
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User mode alows node and reach parameters to be edited without changing the display or structure of
the network. Separating the program operation into 2 modes prevents accidental changes to the
network display or structure when only the parameters are to be edited.

C) Design a Network

To start a new network the menu option ‘File’->"New’ is selected. A dialog is displayed asking for
the coordinates of the area to be displayed to be entered. This can be modified a any time by
selecting the menu option to zoom out or in. Pressing OK will accept the default.

To create a hode the Node design mode is selected and then the mouse clicked on the view to create a
node at that point. Node design mode is selected from the menu option ‘ Tools' ->'Nodes', or from the
toolbar/toolbox icon, which is a circle with a black center. The mouse cursor changes to a cross with
acirclein the lower right. The mouse can be moved to the position on the screen where the node is to
be created and the left mouse button clicked. The node will be created and a dialog will be shown on
the screen (Figure 4).
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Figure 4. Node dialog.

The didog alows the reference number for the node to be entered, the type of node to be defined, and
optionally the ID labd that is displayed on the map can be changed. The dialog has been designed for
minimal typing. The edit cursor is positioned at the reference number for immediately entry of a new
reference number. Pressing the Enter key at any time will select the ok button. The node types that
can be selected are norma node for confluences and bifurcations, irrigation scheme node, and sink
node. The filename and browse option buttons come into use when an irrigation scheme node typeis
specified, and although not used in the current test version, will associated the irrigation scheme data
with the network. Also to be added to this screen will be a check box to indicate if a node received
any externa inflows. If it does then a browse and filename selection box will appear, and the
filenames specified used in the creation of the inflows file for the network. The reference number will
default to the next available reference by finding the largest node reference and adding one to the
value.

A number of nodes may be created without connecting reaches by clicking the mouse on different
map positions and entering a different reference number for each node. To zoom into the map it is
necessary to select edit mode by selecting the menu option ‘Tools ->'Edit datal or magnifying glass
toolbar/toolbox icon. The mouse is then used to click and drag an area to be selected. The node edit
mode must be reselected if more nodes are to be added.

When a few nodes have been created, reaches can be provided to connect the nodes together. To
create a reach, reach design mode is selected. The mouse is then clicked on a node to start a reach.

5-3
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After selecting whether the first node is upstream or downstream, the mouse can be clicked anywhere
on the map to create ‘waypoints' that the reach will follow, prior to clicking on a node to finish the
reach. When the menu option ‘Tools ->'Reaches or the toolbar/toolbox icon which looks by a link
connecting two nodes is selected, the mouse cursor will change to a cross hair with aline connecting 2
points in the lower left. The mouse is moved over a node and the left mouse button pressed. Thereis
then a prompt for indicating if the node is at the upstream or downstream end of the reach (Figure 5).

Choose Reach Ori...
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Figure5 Choose reach orientation dialog.

After selecting with the mouse, either upstream or downstream, it is possible to click on the view to
create waypoints for the reach to follow. A number of waypoints can be created for the reach,
although are not mandatory. To finish a reach, the mouse is moved over a node and the left mouse
button pressed. The reach is then created created and the dialog shown in Figure 6 will be displayed
on the screen.
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Figure 6 Reach dialog.

The dialog alows the reference number to be entered and the upstream and downstream nodes to be
redefined. Reach capacity, reach length and gains & losses for the reach can also be entered. At
present only the reach capacity is used in the model, but an additional objective function incorporating
conveyance efficiency can be added. This dialog has also been designed for minimal typing. The edit
cursor is positioned at the reference number for immediately entry of a new reference number.
Pressing the enter key at any time will select the ok button. The reference number defaults to the next
available reference by finding the largest reach reference and adding one to that value.

d) Moving network components

Selecting ‘select design’ mode, then by clicking and dragging components to a new position can
change the position of nodes and reach waypoints. The menu option ‘Tools->'Select’ or
toolbar/toolbox icon which looks like a mouse arrow is selected and the mouse moved over a node
and the left button pressed to highlight the node. The mouse cursor will change to afour arrow pointer
indicating that the node can be moved. By clicking and holding down the left mouse button and
moving the mouse the node can be dragged to a new position.
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A connecting reach will only move its last waypoint to follow the node. To move reach waypoints the
reach must be selected and each waypoint moved individualy. The mouse is moved over areach and
the left mouse button pressed to select the reach. The reach and all waypoints will be highlighted.
When the mouse is moved over a waypoint, the mouse cursor will change to a four-arrow pointer to
denote that the waypoint can be moved. By clicking and holding down the left mouse button and
moving the mouse the waypoint can be dragged to a new position.

€) Editing nodes and reaches

Although all the node and reaches parameters can be defined at creation of the node or reach, it is
inevitable that some editing of parameters will be required. In order to edit parameters, user mode
must be selected and then the mouse double clicked over the node or reach that is to be edited. The
menu option ‘Tools -> Edit datal or the toolbar/toolbox icon that looks like a magnifying glass is
selected and the mouse moved over the node or reach to be edited. A double click of the left mouse
button displays the edit dialog.

f) Edit the background

The operation to create and edit graphic primitives such as lines, polygons, text and points is the same
sequence of operations as for creation of nodes and reaches. The appropriate menu option or
toolbar/toolbox icon is used to select the desired mode.

To save the network the menu option ‘File' ->'Save as' is selected to enter a filename.
0) M odéel

When the network and background schematic have been created and saved, it is possible to run the
optimisation model. The mode requires the network file to be created before it is run. The menu
option ‘Model’->'Build model files' is selected to show a file selector dialog. It is then possible to
navigate to the directory where the network file isto be saved and to enter the filename with extension
NTA. Inafull implementation, this function would be extended to include creation of the inflow file,
and checking for the existence of al other files required to run the model

The model can currently be run by selecting the menu option ‘Model’->"Run Model’ to show afile
selector diadlog. It is then possible to navigate to the model directory and select the program to be
executed. When an executable is selected, the program will be spawned in a new window. The
OPTALL_NET program will continue to function during the model run. In afull implementation, the
model would be run from the main opening menu, rather than from the OPTALL_NET program.

A complete list of menu option and toolbar/toolbox icons and their descriptions is given below.

For information on other aspects of the OptAll data requirements, reference should by made to the
project report (http://www.civ.ed.ac.uk/research/rbw). For an inexperienced user, the manner in which
the cropping files are set up at present is rather complicated and a graphical interface in which the
cropping calendar can be adjusted on screen would be more appropriate.
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‘Edit’ menu
Undo

Cut

Copy
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‘View' menu
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Create a new network. Program will ask you for the initial map coordinates to display

Allows you to load a previously saved network file. Note that thisis not the file
created from the menu option Model->Build model files.

Close the current network.

Allows you to save the current network to afile. If thisis a new network you will
asked to enter afilename.

Allows you to save the current network under a new filename

Print the current network on the selected printer
Show a print preview
Allows you to select the printer and its properties

Exits the program

Undo’s the last data entry

Removes the highlight node, reach or graphic primitive from the display. Use thisto
remove nodes and reaches form the network

This option is not used

This option is not used

This option shows the display and network as series of objects. Thisis used for
defining background maps with auto mapping and changing the Z order of
components. The use of these features is out of the scope of this manual. Any
changes made here can cause the program to crash.

Show the whole map and network

Zoom out the display too show more map

Previous Zoom Return to previous view

Map Grid

Goto Coordinate

Show/Hide the map grid

Goto a coordinate, enter X,y in adialog
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Set the view to show a map area from diagonal coordinates entered in a dialog

Background colour Change the map background colour

Solid colours only Enable/Disable colour half tones

Toolbox

Toolbar
Status bar
Cross hair
Legend

Show ID

‘Map’ menu

Show/Hide the toolbox. The toolbox contains the icon to select al the design modes
And edit mode. Thisis afloating window which overlays the map

Show/hide the toolbar

Show/hide the status bar. The Status bar shows the select object ID

Show/hide a cross hair which shows the centre of the view

Show/hide the legend

Show/hide the network IDS. Y ou can optional define alabel for your nodes and

reaches rather than display the reference number. This enables you to give more
meaning full names to structures in your network.

Import DXF maps Allows you to import a DXF map which is display undernesth the network.

The DXF file must have the same coordinate system as the view. Y ou can
import as many DXF files as you wish, but all DXF imports are display at the
same time. After selecting the map you will be able to select some import
options, it is best to leave these at the default and press ok to continue. Note
that the DXF file should have a not border defining the edges as this could be
imported as a polgon positioned on topmost obscuring the detail underneath

Remaove DXf map Allows you to remove a previously imported DXF map

‘Model” menu

Build Model files Allows you to create the network file used by the model
Run Model Allows you to select a program to be run

e
]

‘Is menu
Edit Data

Select

Nodes

Selects User mode where you can only edit a nodes or reaches data. Y ou will not be
able to change the network structure such as creating new nodes or repositioning
nodes

Selects Design mode to let you change the position of nodes and reach waypoints by
click and dragging them. Y ou can also reposition points and text graphic primitives
and reposition the waypoints for lines and polygon graphic primitives. When in thus
mode, you can double click on areach or graphic primitive to show its structure
dialog. Thisdialog alows you to change the colour. Note that the node’s colour is
based on its type.

Select design mode to create nodes by clicking the left mouse button on the view
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Select design mode to create reaches by clicking on one node, then a number of
waypoints to route the reach to the last a node.

Select design mode to create lines. Click the left mouse button to start the line, further
clicks create addition segments to the line. Double click the left mouse button to end
theline

Select design mode to create polygons. Click the left mouse button to start the line,
further clicks create addition segments to the polygon. Double click the left mouse
button to end the polygon.

Select design mode to create points. Click the left mouse button on the map to create
apoint. A point can be acircle, triangle or rectangle.

Select design mode to create text strings. Click the left mouse button on the map to
create atext. A dialog will be shown for you to enter the string in the ID field and
select the point size. The point size is based on map units.

Select design mode to create bitmaps. Click the left mouse button on the map to
create a bitmap. A dialog will be shown for you to enter the pathnamein the ID field.

Select the colour to be used when creating graphic primitives.

Transform coordinates This menu option is not used

Convert to line This menu option is only available if you have highlight a polygon. Thiswill convert

the highlighted polygon into aline.

Convert to region This menu option is only available if you have highlight aline. Thiswill convert the

highlighted line into a polgyon.
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